A
Albert
My current code to this problem:
Problem E: Jolly Jumpers
A sequence of n > 0 integers is called a jolly jumper if the absolute
values of the difference between successive elements take on all the
values 1 through n-1. For instance,
1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1
respectively. The definition implies that any sequence of a single
integer is a jolly jumper. You are to write a program to determine
whether or not each of a number of sequences is a jolly jumper.
Input
Each line of input contains an integer n <= 3000 followed by n integers
representing the sequence.
Output
For each line of input, generate a line of output saying "Jolly" or "Not
jolly".
Sample Input
4 1 4 2 3
5 1 4 2 -1 6
Sample Output
Jolly
Not jolly
is:
#include <stdio.h>
#define MAXN 2999
#define MAXDIFF 2999
/* read: read n numbers into a */
void read(int n, int a[])
{
int i;
for (i = 0; i < n; i++)
scanf("%d", a + i);
}
int absdiff(int a, int b)
{
return a>b ? a-b : b-a;
}
int isjolly(int n, int a[])
{
if (n == 1)
return 1;
else {
int takenon[MAXDIFF], i;
for (i = 1; i <= n-1; i++)
takenon = 0;
for (i = 0; i < n-1; i++)
takenon[absdiff(a, a[i+1])] = 1;
for (i = 1; i <= n-1 && takenon; i++)
;
return i == n ? 1 : 0;
}
}
int main()
{
int n, num[MAXN];
int i;
while (scanf("%d", &n)) {
if (n) {
read(n, num);
if (isjolly(n, num))
puts("Jolly");
else
puts("Not jolly");
}
}
return 0;
}
How do I get my program to detect an empty line of input? That is, where
just enter is pressed?
TIA,
Albert
Problem E: Jolly Jumpers
A sequence of n > 0 integers is called a jolly jumper if the absolute
values of the difference between successive elements take on all the
values 1 through n-1. For instance,
1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1
respectively. The definition implies that any sequence of a single
integer is a jolly jumper. You are to write a program to determine
whether or not each of a number of sequences is a jolly jumper.
Input
Each line of input contains an integer n <= 3000 followed by n integers
representing the sequence.
Output
For each line of input, generate a line of output saying "Jolly" or "Not
jolly".
Sample Input
4 1 4 2 3
5 1 4 2 -1 6
Sample Output
Jolly
Not jolly
is:
#include <stdio.h>
#define MAXN 2999
#define MAXDIFF 2999
/* read: read n numbers into a */
void read(int n, int a[])
{
int i;
for (i = 0; i < n; i++)
scanf("%d", a + i);
}
int absdiff(int a, int b)
{
return a>b ? a-b : b-a;
}
int isjolly(int n, int a[])
{
if (n == 1)
return 1;
else {
int takenon[MAXDIFF], i;
for (i = 1; i <= n-1; i++)
takenon = 0;
for (i = 0; i < n-1; i++)
takenon[absdiff(a, a[i+1])] = 1;
for (i = 1; i <= n-1 && takenon; i++)
;
return i == n ? 1 : 0;
}
}
int main()
{
int n, num[MAXN];
int i;
while (scanf("%d", &n)) {
if (n) {
read(n, num);
if (isjolly(n, num))
puts("Jolly");
else
puts("Not jolly");
}
}
return 0;
}
How do I get my program to detect an empty line of input? That is, where
just enter is pressed?
TIA,
Albert