D
dm1608
I'm relatively new to ASP.NET 2.0 and am struggling with trying to find the
best naming convention for the BAL and DAL objects within my database. Does
anyone have any recommendations or best practices for naming my objects?
I currently have all my type classses simply called "JobSummaryClass" or
"JobDetailsClass". These classes simply contain the public properties and
the get/set functions for the object. Is this an appropriate naming
convention?
I then have a BAL class that I call simply JobSummaryComponent that contains
all my BAL logic for the various classes.
Finally, I have a DAL class that I call "JobSummary" that contains my DAL.
It seems that my naming convention doesn't really represent whether its a
BAL or DAL and I'm just wondernig if I'm doing this the best way. My
current BAL for JobSummaryComponent contains the code for querying and using
the JobSummaryClass and JobDetailsClass above. So my thought of calling
this BAL JobSummaryComponent shoudl probably be renamed simply to
JobComponentBAL or something.
Also, should I create a separate source file per object or try and put all
related objects/classes within same source??
Opinions?
best naming convention for the BAL and DAL objects within my database. Does
anyone have any recommendations or best practices for naming my objects?
I currently have all my type classses simply called "JobSummaryClass" or
"JobDetailsClass". These classes simply contain the public properties and
the get/set functions for the object. Is this an appropriate naming
convention?
I then have a BAL class that I call simply JobSummaryComponent that contains
all my BAL logic for the various classes.
Finally, I have a DAL class that I call "JobSummary" that contains my DAL.
It seems that my naming convention doesn't really represent whether its a
BAL or DAL and I'm just wondernig if I'm doing this the best way. My
current BAL for JobSummaryComponent contains the code for querying and using
the JobSummaryClass and JobDetailsClass above. So my thought of calling
this BAL JobSummaryComponent shoudl probably be renamed simply to
JobComponentBAL or something.
Also, should I create a separate source file per object or try and put all
related objects/classes within same source??
Opinions?