J
jasonkester
Most of the sites that I build have to deal with security at some
point, and this means that somewhere in the database there needs to be
a list of Users.
The naming convention that I (and most everybody I've ever worked with
that cares about such things) use dictates that a table should be named
according to what it contains, and that this name should be singular.
So, Customer, User, Entry are all good, while Customers, Users, Entries
are not so good. Thus, nobody has to deal with Junior Dev Jimmy's
magic ID generation code that occasionally tries to bind a column to
"EntrieID".
The issue I keep running into is that "User" is essentially a reserved
word in ASP.NET, being a property of Page. Thus, I can't use it as the
ClassName for my DataObject that wraps the User table. Thus, I
probably shouldn't be naming the table "User", since every other
DataObject always is named after the table it represents.
I've tried going with "Login" to describe users, but this usually
crashes into somebody's Login.aspx Page object, and besides it's not
quite descriptive enough for my tastes.
That leaves us with "Users" (thus breaking our naming convention),
"tblUser" "UserTable" or "UserRecord" (which all look silly on the
url), "Individual" or "Dude" (which I've actually gone with in the
past).
I'm curious what other people have come up with to attack this problem.
I'm sure I'm not the only one running into it. Let me know what you
think!
Jason Kester
Expat Software Consulting Services
http://www.expatsoftware.com/
point, and this means that somewhere in the database there needs to be
a list of Users.
The naming convention that I (and most everybody I've ever worked with
that cares about such things) use dictates that a table should be named
according to what it contains, and that this name should be singular.
So, Customer, User, Entry are all good, while Customers, Users, Entries
are not so good. Thus, nobody has to deal with Junior Dev Jimmy's
magic ID generation code that occasionally tries to bind a column to
"EntrieID".
The issue I keep running into is that "User" is essentially a reserved
word in ASP.NET, being a property of Page. Thus, I can't use it as the
ClassName for my DataObject that wraps the User table. Thus, I
probably shouldn't be naming the table "User", since every other
DataObject always is named after the table it represents.
I've tried going with "Login" to describe users, but this usually
crashes into somebody's Login.aspx Page object, and besides it's not
quite descriptive enough for my tastes.
That leaves us with "Users" (thus breaking our naming convention),
"tblUser" "UserTable" or "UserRecord" (which all look silly on the
url), "Individual" or "Dude" (which I've actually gone with in the
past).
I'm curious what other people have come up with to attack this problem.
I'm sure I'm not the only one running into it. Let me know what you
think!
Jason Kester
Expat Software Consulting Services
http://www.expatsoftware.com/